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When Jamf Now deploys Self Service it displays "Cannot reach a Jamf MDM server"

Updated over 2 months ago

Issue Description

When launching Self Service after Jamf Now deploys it to a Mac, the sidebar briefly appears and then changes to blank window with the message “Cannot reach a Jamf MDM Server” at the bottom.

Cause

There are two potential causes of this behavior:

  1. Self Service will install and be available to all local user accounts on the Mac but it will only successfully open when launched from the local Mac user account that enrolled into Jamf Now. All non-managed local Mac user accounts will experience the above behavior when launching Self Service.

  2. Self Service currently has an MDM check when it launches. When a Mac was once previously managed under Jamf Pro before being managed by Jamf Now, this MDM check sometimes attempt to enroll the Mac's Self Service into the previous Jamf Pro MDM server instead of the current Jamf Now MDM.

Troubleshooting Steps

  1. Signed in as the local user seeing the message in Self Service, check to see if the Jamf Now Enrollment profile is showing in System Settings.

    • If the Enrollment profile is under the wrong local user, we will need to re-enroll the Mac.

      1. Send the Unenroll command using Jamf Now.

      2. Restart the Mac and confirm the profile is no longer visible for the previous user.

      3. Then re-enroll under the desired local Mac user account using a method below:

  2. Look at the Self Service Debug log for a Self Service entry saying: Connecting to Server: *.jamfcloud.com

    1. Open Finder, click Go in the menu bar, and choose Go to Folder.

    2. Enter ~/Library/Logs/JAMF/selfservice_debug.log.

    3. Search for Connecting to Server: *.jamfcloud.com

      • This is a sign the Mac was once managed by Jamf Pro and that Self Service on the Mac is trying to enroll into the old Jamf Pro MDM. Even after wiping and reinstalling macOS, this might persist.

  3. If you find the entry, follow the steps below to resolve the issue:

    1. Quit Self Service.

    2. Using Finder's Go to Folder, search for: /Library/Preferences

    3. Locate com.jamfsoftware.jamf.plist and delete it or move it out of the folder.

    4. Relaunch Self Service. It should now launch as expected and the debug logs should now show: Connecting to Server: *.api.services.jamfnow.com

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