Skip to main content

Values in User and Location keep reverting

Updated over 2 months ago

Issue Description

'User and Location' information in Jamf Pro device inventory records keep changing after the device updates inventory.

Possible Causes

1. Having any 'active' data in an inventory preload will overwrite values every time the device collects inventory.

2. 'Collect user and location information from LDAP' is enabled in Jamf Pro under Settings > Device/Computer management > Inventory Collection.


​Troubleshooting Steps

  1. In Jamf Pro, check under Settings > Global > Inventory Preload for an active Inventory Preload. If there is, either:

    1. Edit the Inventory Preload to remove the serial numbers in question or

      • Note: Deleting active data will remove all data from previously uploaded CSV files. Device inventory details will no longer be updated. All previously applied updates to device inventory will remain intact.

  2. Check to see if Collect user and location information from LDAP is enabled under Settings > Device management > Inventory Collection or Settings > Computer management > Inventory Collection. If it is, either:

    1. Update the information in LDAP or

    2. Disable the Collect user and location information from LDAP.

Did this answer your question?