Issue Description
After in-house or volume purchased apps are scoped to macOS devices through Jamf School, apps hang in an Installing state and never install on the computer.
Cause
This is often caused by the Restrictions profile setting 'Require admin password to install or update apps' which was deprecated by Apple for computers above macOS 10.15. Having this restriction enabled in a profile installed on computers with macOS 11 and greater can cause issues with application installs.
Troubleshooting Steps
Check profiles that have the Restrictions payload enabled for the 'Require admin password to install or update apps' setting under Apps > App Store. If you find profiles with the setting enabled:
Uncheck the box enforcing this setting.
Click Save.
Refresh the device(s) experiencing the installs pending and check the device inventory record under Managed Profiles to ensure the profile has reinstalled.
If the device refresh is not triggering the reinstall, it can be sent:
individually:
Open the individual device record.
Select Managed Apps from the menu on the left.
Click Reinstall for the necessary apps.
in bulk:
In Jamf School go to Apps > Inventory.
Check the box for the apps that are stuck "Installing."
Click Retry and then click Retry to install apps stuck on Installing.